Ubuntu上怎么安装Eclipse Android 开发环境

2012年12月23日 发表评论 阅读评论

从这上面http://www.bananawolf.com/html/2011/06/628.html转载

《Android SDK 开发范例大全》

这本书上在安装开发环境方面讲的不是很详细,而且只有Win上的环境配置方法,没有Ubuntu上的环境配置方法。现代我们就来看看Ubuntu上怎么安装Eclipse+Android的开发环境。

1. 安装JDK6

先确认已经添加了软件源,在系统-系统管理-软件源-其它软件,确保已经选中http://archive.canonical.com/ubuntu lucid partner这个源。

sudo apt-get install sun-java6-jdk

设置系统环境变量

export JAVA_HOME=/usr/lib/jvm/java-6-sun    (根据具体的安装路径)
export ANDROID_JAVA_HOME=$JAVA_HOME

2. 安装Eclipse

在应用程序-Ubuntu软件中心 中查找安装

3.安装Android SDK

在http://developer.android.com/sdk上下载android-sdk_r11-linux_x86.tgz
然后解压到/opt下

sudo tar xzvf android-sdk_r11-linux_x86.tgz -C /opt
# 修改目录权限,
sudo chown -R root:root /opt/android-sdk-linux_x86   root为你当前用户或者
sudo chmod 777 /opt/android-sdk-linux_x86

添加PATH路径

sudo gedit ~/.bashrc

在文件最后输入

# android sdk
export PATH=${PATH}:/opt/android-sdk-linux_x86/tools

4.安装ADT插件
打开上面安装的Eclipse-help-Install New Software

work width为http://dl-ssl.google.com/Android/eclipse/
选择安装android development tools

如果安装过程中出现错误:The operation cannot be completed. See the details
则表明需要安装WST,输入地址http://download.eclipse.org/releases/galileo/
选择最后一项的最后一个子项WST即可,如果安装WST的过程出现错误:An error occurred while installing the items
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null –> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.
有可能没有安装Eclipse 的eclipse-pde或eclipse-jdt插件

sudo apt-get install eclipse-pde
sudo apt-get install eclipse-jdt

5.设置SDK-HOME
在Eclipse 中window-Preferences->android中浏览选择Android SDK的安装目录即/opt/android-sdk-linux_x86

更新Android SDK Tools,
在Eclipse – window – Android SDK and AVD Manager – Installed packages 选择 Android SDK Tools, revision 11点击Update All

至此,Eclipse+Android 环境基本配置完成。


转载请注明来自:[MSN Spaces]http://msn.shandian.biz/499.html

  1. 本文目前尚无任何评论.